using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z_][a-z]*(?:[A-Z][a-z0-9]+)*[a-z0-9_]?$";
string input = @"testAtest_
testAtesta
_testAtest_
_testAtest
_testAt
_testAtestAtest
a
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}