import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z_][a-z]*(?:[A-Z][a-z0-9]+)*[a-z0-9_]?$";
final String string = "testAtest_\n"
+ "testAtesta\n"
+ "_testAtest_\n"
+ "_testAtest\n"
+ "_testAt\n"
+ "_testAtestAtest\n"
+ "a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}