$re = '/^[a-z_][a-z]*(?:[A-Z][a-z0-9]+)*[a-z0-9_]?$/m';
$str = 'testAtest_
testAtesta
_testAtest_
_testAtest
_testAt
_testAtestAtest
a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);