package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z_][a-z]*(?:[A-Z][a-z0-9]+)*[a-z0-9_]?$`)
var str = `testAtest_
testAtesta
_testAtest_
_testAtest
_testAt
_testAtestAtest
a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}