using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(.+?)((?:(\s*,\s*)(.+?))*?)\}";
string input = @"String A ""B"" <c> (D) {autoupdate=""false"", alexa=""ThermostatController.thermostatMode"" [OFF=""OFF"", HEAT=""ON"", AUTO=""AUTO""], test2=""true""}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}