const regex = /\{(.+?)((?:(\s*,\s*)(.+?))*?)\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(.+?)((?:(\\s*,\\s*)(.+?))*?)\\}', 'gm')
const str = `String A "B" <c> (D) {autoupdate="false", alexa="ThermostatController.thermostatMode" [OFF="OFF", HEAT="ON", AUTO="AUTO"], test2="true"}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}