$re = '/\{(.+?)((?:(\s*,\s*)(.+?))*?)\}/m';
$str = 'String A "B" <c> (D) {autoupdate="false", alexa="ThermostatController.thermostatMode" [OFF="OFF", HEAT="ON", AUTO="AUTO"], test2="true"}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);