re = /\{(.+?)((?:(\s*,\s*)(.+?))*?)\}/m
str = 'String A "B" <c> (D) {autoupdate="false", alexa="ThermostatController.thermostatMode" [OFF="OFF", HEAT="ON", AUTO="AUTO"], test2="true"}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end