import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:lazy_)?ngtxt\\(([\\\"\\'])((?:(?!\\1)[^\\\\]|\\\\.)+)\\1,\\s*([\\\"\\'])((?:(?!\\3)[^\\\\]|\\\\.)+)\\3,\\s*(?:.+?)\\)";
final String string = "* ngtxt('i am in single-quotes', 'i am in single-quotes 2', foo)\n"
+ "* ngtxt('i have \\' an escaped single-quote within single-quotes', 'i have \\' an escaped single-quote within single-quotes 2', foo)\n"
+ "* ngtxt('i have a \"double-quote\" in single-quotes', 'i have a \"double-quote\" in single-quotes 2', foo)\n"
+ "* ngtxt(\"i am in double-quotes\", \"i am in double-quotes 2\", foo)\n"
+ "* ngtxt(\"i am in double-quotes with single 'quotes'\", \"i am in double-quotes with single 'quotes' 2\", foo)\n"
+ "* ngtxt('i have an escaped double-quote \\\" within double-quotes', 'i have an escaped double-quote \\\" within double-quotes 2', foo)\n"
+ "* ngtxt('i am singular in single-quotes', \"i am plural in double-quotes\", foo)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}