$re = '/(?:lazy_)?ngtxt\(([\"\'])((?:(?!\1)[^\\\\]|\\\\.)+)\1,\s*([\"\'])((?:(?!\3)[^\\\\]|\\\\.)+)\3,\s*(?:.+?)\)/m';
$str = '* ngtxt(\'i am in single-quotes\', \'i am in single-quotes 2\', foo)
* ngtxt(\'i have \\\' an escaped single-quote within single-quotes\', \'i have \\\' an escaped single-quote within single-quotes 2\', foo)
* ngtxt(\'i have a "double-quote" in single-quotes\', \'i have a "double-quote" in single-quotes 2\', foo)
* ngtxt("i am in double-quotes", "i am in double-quotes 2", foo)
* ngtxt("i am in double-quotes with single \'quotes\'", "i am in double-quotes with single \'quotes\' 2", foo)
* ngtxt(\'i have an escaped double-quote \\" within double-quotes\', \'i have an escaped double-quote \\" within double-quotes 2\', foo)
* ngtxt(\'i am singular in single-quotes\', "i am plural in double-quotes", foo)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);