use strict;
my $str = '* ngtxt(\'i am in single-quotes\', \'i am in single-quotes 2\', foo)
* ngtxt(\'i have \\\' an escaped single-quote within single-quotes\', \'i have \\\' an escaped single-quote within single-quotes 2\', foo)
* ngtxt(\'i have a "double-quote" in single-quotes\', \'i have a "double-quote" in single-quotes 2\', foo)
* ngtxt("i am in double-quotes", "i am in double-quotes 2", foo)
* ngtxt("i am in double-quotes with single \'quotes\'", "i am in double-quotes with single \'quotes\' 2", foo)
* ngtxt(\'i have an escaped double-quote \\" within double-quotes\', \'i have an escaped double-quote \\" within double-quotes 2\', foo)
* ngtxt(\'i am singular in single-quotes\', "i am plural in double-quotes", foo)
';
my $regex = qr/(?:lazy_)?ngtxt\(([\"\'])((?:(?!\1)[^\\]|\\.)+)\1,\s*([\"\'])((?:(?!\3)[^\\]|\\.)+)\3,\s*(?:.+?)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}