package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^1?[0-9][0-9]:[0-5][0-9]$`)
var str = `00:00
90:00
99:59
199:00
200:00
50:70
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}