import re
regex = re.compile(r"^1?[0-9][0-9]:[0-5][0-9]$", flags=re.MULTILINE)
test_str = ("00:00\n"
"90:00\n"
"99:59\n"
"199:00\n"
"200:00\n"
"50:70\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")