// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^1?[0-9][0-9]:[0-5][0-9]$").unwrap();
let string = "00:00
90:00
99:59
199:00
200:00
50:70
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}