$re = '/^1?[0-9][0-9]:[0-5][0-9]$/m';
$str = '00:00
90:00
99:59
199:00
200:00
50:70
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);