import re
regex = re.compile(r"^((0[1-9]|1[0-2])|([1-9]{1}))\/([0-9]{4}|[0-9]{2})$", flags=re.MULTILINE)
test_str = ("02/13\n"
"0213\n"
"022013\n"
"02/2013\n"
"02/20\n"
"02/2\n"
"02/2032")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")