import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\h+[A-Z][a-z.]+)+$";
final String string = "Allow these\n"
+ "123 Main St\n"
+ "123 Main St.\n"
+ "1504 Eagle Point Way\n"
+ "1024 McKinley Ave NW\n"
+ "7813 Peña Blanca Street\n\n"
+ "Don’t allow these\n"
+ "123 MAIN ST\n"
+ "123 main st\n"
+ "1504 EAGLE point wAy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}