use strict;
my $str = 'Allow these
123 Main St
123 Main St.
1504 Eagle Point Way
1024 McKinley Ave NW
7813 Peña Blanca Street
Don’t allow these
123 MAIN ST
123 main st
1504 EAGLE point wAy';
my $regex = qr~^\d+(?:\h+[A-Z][a-z.]+)+$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}