import Foundation
let pattern = #"^\d+(?:\h+[A-Z][a-z.]+)+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Allow these
123 Main St
123 Main St.
1504 Eagle Point Way
1024 McKinley Ave NW
7813 Peña Blanca Street
Don’t allow these
123 MAIN ST
123 main st
1504 EAGLE point wAy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)