$re = '~^\d+(?:\h+[A-Z][a-z.]+)+$~m';
$str = 'Allow these
123 Main St
123 Main St.
1504 Eagle Point Way
1024 McKinley Ave NW
7813 Peña Blanca Street
Don’t allow these
123 MAIN ST
123 main st
1504 EAGLE point wAy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);