import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^(([^`]*(?<!\\\\)`[^`]*(?<!\\\\)`[^`]*)*))([*_])([^`*_]+?)\\3(?![*_])";
final String string = "a*a `hello * world` *to you too* \n"
+ "([*_])([^\\`*_]+?)\\1(?![*_])\n"
+ "hello you `hello * world` *to us too*\n"
+ "I'm *blah* `ini*set(\"display*errors\", 1); error*reporting(E*ALL);` but *should* match this.\n\n"
+ "*But* I'm *just* trying to\n"
+ "*reporting(E* or *set(\"display*\n"
+ "([*_])([^`*_]+?)\\1(?![*_])\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}