re = /(?<=^(([^`]*(?<!\\)`[^`]*(?<!\\)`[^`]*)*))([*_])([^`*_]+?)\3(?![*_])/m
str = 'a*a `hello * world` *to you too*
([*_])([^\\`*_]+?)\\1(?![*_])
hello you `hello * world` *to us too*
I\'m *blah* `ini*set("display*errors", 1); error*reporting(E*ALL);` but *should* match this.
*But* I\'m *just* trying to
*reporting(E* or *set("display*
([*_])([^`*_]+?)\\1(?![*_])
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end