const regex = /(?<=^(([^`]*(?<!\\)`[^`]*(?<!\\)`[^`]*)*))([*_])([^`*_]+?)\3(?![*_])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^(([^`]*(?<!\\\\)`[^`]*(?<!\\\\)`[^`]*)*))([*_])([^`*_]+?)\\3(?![*_])', 'gm')
const str = `a*a \`hello * world\` *to you too*
([*_])([^\\\`*_]+?)\\1(?![*_])
hello you \`hello * world\` *to us too*
I'm *blah* \`ini*set("display*errors", 1); error*reporting(E*ALL);\` but *should* match this.
*But* I'm *just* trying to
*reporting(E* or *set("display*
([*_])([^\`*_]+?)\\1(?![*_])
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}