use strict;
my $str = 'a*a `hello * world` *to you too*
([*_])([^\\`*_]+?)\\1(?![*_])
hello you `hello * world` *to us too*
I\'m *blah* `ini*set("display*errors", 1); error*reporting(E*ALL);` but *should* match this.
*But* I\'m *just* trying to
*reporting(E* or *set("display*
([*_])([^`*_]+?)\\1(?![*_])
';
my $regex = qr/(?<=^(([^`]*(?<!\\)`[^`]*(?<!\\)`[^`]*)*))([*_])([^`*_]+?)\3(?![*_])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}