import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(https?:\\/\\/(?:[^\\/]+\\/){9})(.*)$";
final String string = "https://www.example.com/img/public/vendor1/us/en/product-assets/vendor/product/green/device_230x400_a.gif";
final String subst = "$1image/$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}