const regex = /^(https?:\/\/(?:[^\/]+\/){9})(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(https?:\\\/\\\/(?:[^\\\/]+\\\/){9})(.*)$', 'gm')
const str = `https://www.example.com/img/public/vendor1/us/en/product-assets/vendor/product/green/device_230x400_a.gif`;
const subst = `$1image/$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);