import re
regex = re.compile(r"^(https?:\/\/(?:[^\/]+\/){9})(.*)$", flags=re.MULTILINE)
test_str = "https://www.example.com/img/public/vendor1/us/en/product-assets/vendor/product/green/device_230x400_a.gif"
subst = "$1image/$2"
result = regex.sub(subst, test_str)
if result:
print(result)