re = /^(https?:\/\/(?:[^\/]+\/){9})(.*)$/m
str = 'https://www.example.com/img/public/vendor1/us/en/product-assets/vendor/product/green/device_230x400_a.gif'
subst = '$1image/$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result