#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)'apiKey'\s*=>\s*'\K[^']+"
Local $sString = "'apiKey' => '1234567890'"
Local $sSubst = "YourAPIKeyHere"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)