$re = '/\'apiKey\'\s*=>\s*\'\K[^\']+/m';
$str = '\'apiKey\' => \'1234567890\'';
$subst = "YourAPIKeyHere";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;