package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[expr\s+)([^}][^\]]*)(\])`)
var str = `set a [expr $sumy+1]
set b [[expr $sumy+1] [expr $sumy+2] [expr $sumy+3]]
set c [expr $sumy+[lindex $coords 1]]
set d [expr [lindex [$ret] 2] + $Alpha]
set e [string range $SECNAME 0 [expr [string first - $SECNAME] -1] ]
(\[expr\s+)([^}][^\]]*)(\])
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}