import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[expr\\s+)([^\\}][^\\]]*)(\\])";
final String string = "set a [expr $sumy+1]\n"
+ "set b [[expr $sumy+1] [expr $sumy+2] [expr $sumy+3]]\n"
+ "set c [expr $sumy+[lindex $coords 1]]\n"
+ "set d [expr [lindex [$ret] 2] + $Alpha]\n"
+ "set e [string range $SECNAME 0 [expr [string first - $SECNAME] -1] ]\n\n\n"
+ "(\\[expr\\s+)([^}][^\\]]*)(\\])\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}