package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-zA-Z0-9]+`)
var str = `Olympia, WA: SLP Full 40 or Part Time`
var substitution = "-"
fmt.Println(re.ReplaceAllString(str, substitution))
}