$re = '/[^a-zA-Z0-9]+/m';
$str = 'Olympia, WA: SLP Full 40 or Part Time';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;