use strict;
my $str = 'Olympia, WA: SLP Full 40 or Part Time';
my $regex = qr/[^a-zA-Z0-9]+/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";