re = /[^a-zA-Z0-9]+/m
str = 'Olympia, WA: SLP Full 40 or Part Time'
subst = '-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result