const regex = /^
# Validate the basic structure
(?=\d{1,4}\/\d{1,4}\/\d{1,4}$)
# The below subexpression matches a leap year
# This will be useful later when checking Feb 29th
(?<leap>0*$|\d*(?:[13579][26]|(?:\b|[02468])[048])(?:00|(?<!00))$){0}
# Match and capture a month, saving a 30-day month or Feb for later reference
0*(?<month>(?<thirty>9|4|6|11)|(?<feb>2)|1[02]|[13578])\/
# If Feb was matched and 29 appears, check for a leap year
0*(?<day>[1-9]|1\d|2[0-8]|(?(feb)29(?=\/(?&leap))|(?:29|(?(thirty)30|3[01]))))\/
# Match and capture a year
(?:0\B)*(?<year>\d+)
$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
# Validate the basic structure
(?=\\d{1,4}\\\/\\d{1,4}\\\/\\d{1,4}$)
# The below subexpression matches a leap year
# This will be useful later when checking Feb 29th
(?<leap>0*$|\\d*(?:[13579][26]|(?:\\b|[02468])[048])(?:00|(?<!00))$){0}
# Match and capture a month, saving a 30-day month or Feb for later reference
0*(?<month>(?<thirty>9|4|6|11)|(?<feb>2)|1[02]|[13578])\\\/
# If Feb was matched and 29 appears, check for a leap year
0*(?<day>[1-9]|1\\d|2[0-8]|(?(feb)29(?=\\\/(?&leap))|(?:29|(?(thirty)30|3[01]))))\\\/
# Match and capture a year
(?:0\\B)*(?<year>\\d+)
$', 'gm')
const str = `1/25/2018
3/11/2119
6/8/224
6/54/1996
2/29/2004
2/29/1900`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}