import Foundation
let pattern = ##"""
^
# Validate the basic structure
(?=\d{1,4}\/\d{1,4}\/\d{1,4}$)
# The below subexpression matches a leap year
# This will be useful later when checking Feb 29th
(?<leap>0*$|\d*(?:[13579][26]|(?:\b|[02468])[048])(?:00|(?<!00))$){0}
# Match and capture a month, saving a 30-day month or Feb for later reference
0*(?<month>(?<thirty>9|4|6|11)|(?<feb>2)|1[02]|[13578])\/
# If Feb was matched and 29 appears, check for a leap year
0*(?<day>[1-9]|1\d|2[0-8]|(?(feb)29(?=\/(?&leap))|(?:29|(?(thirty)30|3[01]))))\/
# Match and capture a year
(?:0\B)*(?<year>\d+)
$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
1/25/2018
3/11/2119
6/8/224
6/54/1996
2/29/2004
2/29/1900
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)