use strict;
my $str = '1/25/2018
3/11/2119
6/8/224
6/54/1996
2/29/2004
2/29/1900';
my $regex = qr/^
# Validate the basic structure
(?=\d{1,4}\/\d{1,4}\/\d{1,4}$)
# The below subexpression matches a leap year
# This will be useful later when checking Feb 29th
(?<leap>0*$|\d*(?:[13579][26]|(?:\b|[02468])[048])(?:00|(?<!00))$){0}
# Match and capture a month, saving a 30-day month or Feb for later reference
0*(?<month>(?<thirty>9|4|6|11)|(?<feb>2)|1[02]|[13578])\/
# If Feb was matched and 29 appears, check for a leap year
0*(?<day>[1-9]|1\d|2[0-8]|(?(feb)29(?=\/(?&leap))|(?:29|(?(thirty)30|3[01]))))\/
# Match and capture a year
(?:0\B)*(?<year>\d+)
$/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}