#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?[1-9]*?0?(\.\d+)?$"
Local $sString = ".5" & @CRLF & _
"0.500" & @CRLF & _
"3" & @CRLF & _
"0" & @CRLF & _
"0.0" & @CRLF & _
"." & @CRLF & _
"00" & @CRLF & _
"00.5" & @CRLF & _
"-.5" & @CRLF & _
"-0.500" & @CRLF & _
"-3" & @CRLF & _
"-0" & @CRLF & _
"-0.0" & @CRLF & _
"-." & @CRLF & _
"-00" & @CRLF & _
"-00.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")