$re = '/^-?[1-9]*?0?(\.\d+)?$/m';
$str = '.5
0.500
3
0
0.0
.
00
00.5
-.5
-0.500
-3
-0
-0.0
-.
-00
-00.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);