// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?[1-9]*?0?(\.\d+)?$").unwrap();
let string = ".5
0.500
3
0
0.0
.
00
00.5
-.5
-0.500
-3
-0
-0.0
-.
-00
-00.5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}