re = /^-?[1-9]*?0?(\.\d+)?$/m
str = '.5
0.500
3
0
0.0
.
00
00.5
-.5
-0.500
-3
-0
-0.0
-.
-00
-00.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end