using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?\d*\.{0,1}\d+";
string input = @"5239
-14
8358.361167
-0168184.075
17694369.19 salut
-1840175169
-9564.386285toto
584.4015730
-488094.1607
8495.238343";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}