$re = '/-?\d*\.{0,1}\d+/m';
$str = '5239
-14
8358.361167
-0168184.075
17694369.19 salut
-1840175169
-9564.386285toto
584.4015730
-488094.1607
8495.238343';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);