const regex = /-?\d*\.{0,1}\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-?\\d*\\.{0,1}\\d+', 'gm')
const str = `5239
-14
8358.361167
-0168184.075
17694369.19 salut
-1840175169
-9564.386285toto
584.4015730
-488094.1607
8495.238343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}