import re
regex = re.compile(r"-?\d*\.{0,1}\d+", flags=re.MULTILINE)
test_str = ("5239\n"
"-14\n"
"8358.361167\n"
"-0168184.075\n"
"17694369.19 salut\n"
"-1840175169\n"
"-9564.386285toto\n"
"584.4015730\n"
"-488094.1607\n"
"8495.238343")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")