using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{1,2}\.\d{1,2}\.\d{4}(?:\s+\d{1,2}:\d{1,2})?";
string input = @"Hospitalization from 25.1.2018 to 26.1.2018
Date of hospitalization was from 28.8.2019 8:15
Date of arrival 30.6.2018 20:30 to hospital";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}