const regex = /\d{1,2}\.\d{1,2}\.\d{4}(?:\s+\d{1,2}:\d{1,2})?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,2}\\.\\d{1,2}\\.\\d{4}(?:\\s+\\d{1,2}:\\d{1,2})?', 'gm')
const str = `Hospitalization from 25.1.2018 to 26.1.2018
Date of hospitalization was from 28.8.2019 8:15
Date of arrival 30.6.2018 20:30 to hospital`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}