// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,2}\.\d{1,2}\.\d{4}(?:\s+\d{1,2}:\d{1,2})?").unwrap();
let string = "Hospitalization from 25.1.2018 to 26.1.2018
Date of hospitalization was from 28.8.2019 8:15
Date of arrival 30.6.2018 20:30 to hospital";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}